En bref
- CVE-2026-12480 est une vulnérabilité MOYENNE (CVSS 5.5) touchant keras.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.19%, plus élevée que 8.7% des vulnérabilités.
- Correctif : mettre à jour vers 3.15.0, 3.12.3 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| keras PyPI | ≥ 3.13.0, < 3.15.0< 3.12.3
| 3.15.03.12.3
|
Description
Keras versions up to and including 3.13.2 are vulnerable to an arbitrary HDF5 file read due to an incomplete fix for CVE-2026-1669. The vulnerability resides in the H5IOStore._verify_dataset() and file_editor.py methods, which fail to check the dataset.is_virtual property of HDF5 datasets. This allows an attacker to craft a malicious .keras model archive or .h5 weights file containing a Virtual Dataset (VDS) that references external HDF5 files on the victim's filesystem. When the victim loads the model using keras.models.load_model() or keras.saving.load_model(), the external file is transparently read, leading to potential information disclosure. Fixed in versions 3.12.3 and 3.15.0.
NVD description
Keras versions up to and including 3.13.2 are vulnerable to an arbitrary HDF5 file read due to an incomplete fix for CVE-2026-1669. The vulnerability resides in the `H5IOStore._verify_dataset()` and `file_editor.py` methods, which fail to check the `dataset.is_virtual` property of HDF5 datasets. This allows an attacker to craft a malicious `.keras` model archive or `.h5` weights file containing a Virtual Dataset (VDS) that references external HDF5 files on the victim's filesystem. When the victim loads the model using `keras.models.load_model()` or `keras.saving.load_model()`, the external file is transparently read, leading to potential information disclosure. Fixed in versions 3.12.2 and 3.14.1.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free