En bref
- CVE-2026-22250 est une vulnérabilité MOYENNE (CVSS 5.5) touchant wlc, wlc (weblate).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.15%, plus élevée que 4.5% des vulnérabilités.
- Correctif : mettre à jour vers 1.17.0 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| wlc PyPI | < 1.17.0
| 1.17.0
|
| wlc | < 1.17.0
| 1.17.0
|
Description
Impact
The SSL verification would be skipped for some crafted URLs.
Patches
Workarounds
Avoid using untrusted wlc configurations, as that might cause insecure connections.
References
This issue was reported to us by wh1zee via HackerOne.
NVD description
wlc is a Weblate command-line client using Weblate's REST API. Prior to 1.17.0, the SSL verification would be skipped for some crafted URLs. This vulnerability is fixed in 1.17.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free