En bref
- CVE-2026-22750 est une vulnérabilité ÉLEVÉE (CVSS 7.5) touchant org.springframework.cloud:spring-cloud-gateway, spring cloud gateway (vmware).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.22%, plus élevée que 12.2% des vulnérabilités.
- Correctif : mettre à jour vers 4.2.1 ou plus récent.
Description
When configuring SSL bundles in Spring Cloud Gateway by using the configuration property spring.ssl.bundle, the configuration was silently ignored and the default SSL configuration was used instead.
Note: The 4.2.x branch is no longer under open source support. If you are using Spring Cloud Gateway 4.2.0 and are not an enterprise customer, you can upgrade to any Spring Cloud Gateway 4.2.x release newer than 4.2.0 available on Maven Centeral https://repo1.maven.org/maven2/org/springframework/cloud/spring-cloud-gateway/ . Ideally, if you are not an enterprise customer, you should be upgrading to 5.0.2 or 5.1.1, which are the current supported open source releases.
NVD description
When configuring SSL bundles in Spring Cloud Gateway by using the configuration property spring.ssl.bundle, the configuration was silently ignored and the default SSL configuration was used instead.
Note: The 4.2.x branch is no longer under open source support. If you are using Spring Cloud Gateway 4.2.0 and are not an enterprise customer, you can upgrade to any Spring Cloud Gateway 4.2.x release newer than 4.2.0 available on Maven Centeral https://repo1.maven.org/maven2/org/springframework/cloud/spring-cloud-gateway/ . Ideally if you are not an enterprise customer, you should be upgrading to 5.0.2 or 5.1.1 which are the current supported open source releases.
Autres vulnérabilités de org.springframework.cloud:spring-cloud-gateway
Tout voir →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free