En bref
- CVE-2026-23957 est une vulnérabilité ÉLEVÉE (CVSS 7.5) touchant seroval (lxsmnsyc), seroval.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.44%, plus élevée que 38.1% des vulnérabilités.
- Correctif : mettre à jour vers 1.4.1 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| seroval | < 1.4.1
| 1.4.1
|
| seroval npm | < 1.4.1
| 1.4.1
|
Description
Overriding encoded array lengths by replacing them with an excessively large value causes the deserialization process to significantly increase processing time.
Mitigation:
Seroval no longer encodes array lengths.
Instead, it computes length using Array.prototype.length during deserialization.
NVD description
seroval facilitates JS value stringification, including complex structures beyond JSON.stringify capabilities. In versions 1.4.0
and below, overriding encoded array lengths by replacing them with an excessively large value causes the deserialization process to significantly increase processing time. This issue has been fixed in version 1.4.1.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free