En bref
- CVE-2026-24013 est une vulnérabilité CRITIQUE (CVSS 9.1) touchant apache-iotdb, iotdb (apache).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.64%, plus élevée que 50.5% des vulnérabilités.
- Correctif : mettre à jour vers 2.0.8 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| apache-iotdb PyPI | ≥ 1.3.3, < 2.0.8
| 2.0.8
|
| iotdb | ≥ 1.3.3, < 2.0.8
| 2.0.8
|
Description
Authentication Bypass by Spoofing vulnerability in Apache IoTDB.
Certain Thrift RPC query handlers lack strict validation of the sessionId
parameter. An attacker can construct requests with a forged sessionId and,
without performing openSession authentication, receive valid query results.
This allows authentication bypass and unauthorized reading of time-series
data.
This issue affects Apache IoTDB: from 1.3.3 before 2.0.8.
Users are recommended to upgrade to version 2.0.8, which fixes the issue.
NVD description
Authentication Bypass by Spoofing vulnerability in Apache IoTDB.
Certain Thrift RPC query handlers lack strict validation of the sessionId
parameter. An attacker can construct requests with a forged sessionId and,
without performing openSession authentication, receive valid query results.
This allows authentication bypass and unauthorized reading of time-series
data.
This issue affects Apache IoTDB: from 1.3.3 before 2.0.8.
Users are recommended to upgrade to version 2.0.8, which fixes the issue.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free