En bref
- CVE-2026-24688 est une vulnérabilité MOYENNE (CVSS 4.3) touchant pypdf, pypdf (pypdf project).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.45%, plus élevée que 38.7% des vulnérabilités.
- Correctif : mettre à jour vers 6.6.2 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| pypdf PyPI | < 6.6.2
| 6.6.2
|
| pypdf | < 6.6.2
| 6.6.2
|
Description
Impact
An attacker who uses this vulnerability can craft a PDF which leads to an infinite loop. This requires accessing the outlines/bookmarks.
Patches
This has been fixed in pypdf 6.6.2.
Workarounds
If projects cannot upgrade yet, consider applying the changes from PR #3610.
NVD description
pypdf is a free and open-source pure-python PDF library. An attacker who uses an infinite loop vulnerability that is present in versions prior to 6.6.2 can craft a PDF which leads to an infinite loop. This requires accessing the outlines/bookmarks. This has been fixed in pypdf 6.6.2. If projects cannot upgrade yet, consider applying the changes from PR #3610 manually.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free