En bref
- CVE-2026-24844 est une vulnérabilité ÉLEVÉE (CVSS 8.8) touchant chainguard.dev/melange, melange (chainguard).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.20%, plus élevée que 9.7% des vulnérabilités.
- Correctif : mettre à jour vers 0.40.3 ou plus récent.
Description
An attacker who can provide build input values, but not modify pipeline definitions, could execute arbitrary shell commands if the pipeline uses ${{vars.*}} or ${{inputs.*}} substitutions in working-directory. The field is embedded into shell scripts without proper quote escaping.
Fix: Fixed with e51ca30c, Released.
Acknowledgements
melange thanks Oleh Konko from 1seal for discovering and reporting this issue.
NVD description
melange allows users to build apk packages using declarative pipelines. From version 0.3.0 to before 0.40.3, an attacker who can provide build input values, but not modify pipeline definitions, could execute arbitrary shell commands if the pipeline uses ${{vars.*}} or ${{inputs.*}} substitutions in working-directory. The field is embedded into shell scripts without proper quote escaping. This issue has been patched in version 0.40.3.
Autres vulnérabilités de chainguard.dev/melange
Tout voir →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free