En bref
- CVE-2026-25581 est une vulnérabilité MOYENNE (CVSS 5.4) touchant sceditor (sceditor), sceditor.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.24%, plus élevée que 15.9% des vulnérabilités.
- Correctif : mettre à jour vers 3.2.1 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| sceditor | < 3.2.1
| 3.2.1
|
| sceditor npm | < 3.2.1
| 3.2.1
|
Description
If an attacker has the ability control configuration options passed to sceditor.create(), like emoticons, charset, etc. then it's possible for them to trigger an XSS attack due to lack of sanitisation of configuration options.
Proof of concept:
sceditor.create(textarea, {
emoticons: {
dropdown: { ':)': { url: 'x" onerror="window.__xss = true' } }
}
});
NVD description
SCEditor is a lightweight WYSIWYG BBCode and XHTML editor. Prior to 3.2.1, if an attacker has the ability control configuration options passed to sceditor.create(), like emoticons, charset, etc. then it's possible for them to trigger an XSS attack due to lack of sanitisation of configuration options. This vulnerability is fixed in 3.2.1.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free