En bref
- CVE-2026-25747 est une vulnérabilité ÉLEVÉE (CVSS 8.8) touchant org.apache.camel:camel-leveldb, camel (apache).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 1.3%, plus élevée que 69.5% des vulnérabilités.
- Correctif : mettre à jour vers 4.10.9, 4.14.5, 4.18.0 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| org.apache.camel:camel-leveldb Maven | ≥ 3.0.0, < 4.10.9≥ 4.11.0, < 4.14.5≥ 4.15.0, < 4.18.0
| 4.10.94.14.54.18.0
|
| camel | ≥ 3.0.0, < 4.10.9≥ 4.11.0, < 4.14.5≥ 4.15.0, < 4.18.0
| 4.10.94.14.54.18.0
|
Description
Deserialization of Untrusted Data vulnerability in Apache Camel LevelDB component.
The Camel-LevelDB DefaultLevelDBSerializer class deserializes data read from the LevelDB aggregation repository using java.io.ObjectInputStream without applying any ObjectInputFilter or class-loading restrictions. An attacker who can write to the LevelDB database files used by a Camel application can inject a crafted serialized Java object that, when deserialized during normal aggregation repository operations, results in arbitrary code execution in the context of the application.
This issue affects Apache Camel: from 4.10.0 before 4.10.8, from 4.14.0 before 4.14.5, from 4.15.0 before 4.18.0.
Users are recommended to upgrade to version 4.18.0, which fixes the issue. For the 4.10.x LTS releases, users are recommended to upgrade to 4.10.9, while for 4.14.x LTS releases, users are recommended to upgrade to 4.14.5
NVD description
Deserialization of Untrusted Data vulnerability in Apache Camel LevelDB component.
The Camel-LevelDB DefaultLevelDBSerializer class deserializes data read from the LevelDB aggregation repository using java.io.ObjectInputStream without applying any ObjectInputFilter or class-loading restrictions. An attacker who can write to the LevelDB database files used by a Camel application can inject a crafted serialized Java object that, when deserialized during normal aggregation repository operations, results in arbitrary code execution in the context of the application.
This issue affects Apache Camel: from 4.10.0 before 4.10.8, from 4.14.0 before 4.14.5, from 4.15.0 before 4.18.0.
Users are recommended to upgrade to version 4.18.0, which fixes the issue. For the 4.10.x LTS releases, users are recommended to upgrade to 4.10.9, while for 4.14.x LTS releases, users are recommended to upgrade to 4.14.5
Autres vulnérabilités de org.apache.camel:camel-leveldb
Tout voir →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free