En bref
- CVE-2026-26929 est une vulnérabilité MOYENNE (CVSS 6.5) touchant apache-airflow, airflow (apache).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.42%, plus élevée que 36.5% des vulnérabilités.
- Correctif : mettre à jour vers 3.1.8 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| apache-airflow PyPI | ≥ 3.0.0, < 3.1.8
| 3.1.8
|
| airflow | ≥ 3.0.0, < 3.1.8
| 3.1.8
|
Description
Apache Airflow versions 3.0.0 through 3.1.7 FastAPI DagVersion listing API does not apply per-DAG authorization filtering when the request is made with dag_id set to "~" (wildcard for all DAGs). As a result, version metadata of DAGs that the requester is not authorized to access is returned.
Users are recommended to upgrade to Apache Airflow 3.1.8 or later, which resolves this issue.
NVD description
Apache Airflow versions 3.0.0 through 3.1.7 FastAPI DagVersion listing API does not apply per-DAG authorization filtering when the request is made with dag_id set to "~" (wildcard for all DAGs). As a result, version metadata of DAGs that the requester is not authorized to access is returned.
Users are recommended to upgrade to Apache Airflow 3.1.8 or later, which resolves this issue.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free