| Package | Affected versions | Patched versions |
|---|---|---|
| discourse | = 2026.3.0≥ 2026.1.0, < 2026.1.2≥ 2026.2.0, < 2026.2.1< 2026.3.0 | 2026.1.22026.2.12026.3.0 |
Discourse is an open source discussion platform. Prior to versions 2026.3.0-latest.1, 2026.2.1 and 2026.1.2, insufficient cleanup in the default Codepen allowed iframes value allows an attacker to trick a user into changing the URL of the main page. This issue has been fixed in versions 2026.3.0-latest.1, 2026.2.1 and 2026.1.2. To workaround this issue, remove Codepen from the list of allowed iframes.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free