En bref
- CVE-2026-27628 est une vulnérabilité ÉLEVÉE (CVSS 7.5) touchant pypdf, pypdf (pypdf project).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.40%, plus élevée que 33.9% des vulnérabilités.
- Correctif : mettre à jour vers 6.7.2 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| pypdf PyPI | < 6.7.2
| 6.7.2
|
| pypdf | < 6.7.2
| 6.7.2
|
Description
Impact
An attacker who uses this vulnerability can craft a PDF which leads to an infinite loop. This requires reading the file.
Patches
This has been fixed in pypdf==6.7.2.
Workarounds
If users cannot upgrade yet, consider applying the changes from PR #3655.
NVD description
pypdf is a free and open-source pure-python PDF library. Prior to 6.7.2, an attacker who uses this vulnerability can craft a PDF which leads to an infinite loop. This requires reading the file. This has been fixed in pypdf 6.7.2. As a workaround, one may apply the patch manually.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free