En bref
- CVE-2026-27820 est une vulnérabilité CRITIQUE (CVSS 9.8) touchant zlib, zlib (ruby-lang).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.56%, plus élevée que 46.7% des vulnérabilités.
- Correctif : mettre à jour vers 3.1.2, 3.2.3, 3.0.1 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| zlib RubyGems | ≥ 3.1.0, < 3.1.2≥ 3.2.0, < 3.2.3< 3.0.1
| 3.1.23.2.33.0.1
|
| zlib | ≥ 3.1.0, < 3.1.2≥ 3.2.0, < 3.2.3< 3.0.1
| 3.1.23.2.33.0.1
|
Description
Details
A buffer overflow vulnerability exists in Zlib::GzipReader.
The zstream_buffer_ungets function prepends caller-provided bytes ahead of previously produced output but fails to guarantee the backing Ruby string has enough capacity before the memmove shifts the existing data. This can lead to memory corruption when the buffer length exceeds capacity.
Recommended action
We recommend to update the zlib gem to version 3.2.3 or later. In order to ensure compatibility with bundled version in older Ruby series, you may update as follows instead:
- For Ruby 3.2 users: Update to zlib 3.0.1
- For Ruby 3.3 users: Update to zlib 3.1.2
You can use gem update zlib to update it. If you are using bundler, please add gem "zlib", ">= 3.2.3" to your Gemfile.
Affected versions
zlib gem 3.2.2 or lower
Credits
calysteon
References
NVD description
zlib is a Ruby interface for the zlib compression/decompression library. Versions 3.0.0 and below, 3.1.0, 3.1.1, 3.2.0 and 3.2.1 contain a buffer overflow vulnerability in the Zlib::GzipReader. The zstream_buffer_ungets function prepends caller-provided bytes ahead of previously produced output but fails to guarantee the backing Ruby string has enough capacity before the memmove shifts the existing data. This can lead to memory corruption when the buffer length exceeds capacity. This issue has been fixed in versions 3.0.1, 3.1.2 and 3.2.3.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free