En bref
- CVE-2026-27888 est une vulnérabilité ÉLEVÉE (CVSS 7.5) touchant pypdf, pypdf (pypdf project).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.40%, plus élevée que 34.1% des vulnérabilités.
- Correctif : mettre à jour vers 6.7.3 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| pypdf PyPI | < 6.7.3
| 6.7.3
|
| pypdf | < 6.7.3
| 6.7.3
|
Description
Impact
An attacker who uses this vulnerability can craft a PDF which leads to the RAM being exhausted. This requires accessing the xfa property of a reader or writer and the corresponding stream being compressed using /FlateDecode.
Patches
This has been fixed in pypdf==6.7.3.
Workarounds
If projects cannot upgrade yet, consider applying the changes from PR #3658.
NVD description
pypdf is a free and open-source pure-python PDF library. Prior to 6.7.3, an attacker who uses this vulnerability can craft a PDF which leads to the RAM being exhausted. This requires accessing the `xfa` property of a reader or writer and the corresponding stream being compressed using `/FlateDecode`. This has been fixed in pypdf 6.7.3. As a workaround, apply the patch manually.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free