En bref
- CVE-2026-27971 est une vulnérabilité CRITIQUE (CVSS 9.8) touchant qwik (qwik), @builder.io/qwik.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 5.5%, plus élevée que 92.8% des vulnérabilités.
- Correctif : mettre à jour vers 1.19.1 ou plus récent.
Description
Summary
qwik <=1.19.0 is vulnerable to RCE due to an unsafe deserialization vulnerability in the server$ RPC mechanism that allows any unauthenticated user to execute arbitrary code on the server with a single HTTP request. Affects any deployment where require() is available at runtime.
Impact
NVD description
Qwik is a performance focused javascript framework. qwik <=1.19.0 is vulnerable to RCE due to an unsafe deserialization vulnerability in the server$ RPC mechanism that allows any unauthenticated user to execute arbitrary code on the server with a single HTTP request. Affects any deployment where require() is available at runtime. This vulnerability is fixed in 1.19.1.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free