En bref
- CVE-2026-28351 est une vulnérabilité MOYENNE (CVSS 5.3) touchant pypdf, pypdf (pypdf project).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.48%, plus élevée que 41.4% des vulnérabilités.
- Correctif : mettre à jour vers 6.7.4 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| pypdf PyPI | < 6.7.4
| 6.7.4
|
| pypdf | < 6.7.4
| 6.7.4
|
Description
Impact
An attacker who uses this vulnerability can craft a PDF which leads to large memory usage. This requires parsing the content stream using the RunLengthDecode filter.
Patches
This has been fixed in pypdf==6.7.4.
Workarounds
If you cannot upgrade yet, consider applying the changes from PR #3664.
NVD description
pypdf is a free and open-source pure-python PDF library. Prior to version 6.7.4, an attacker who uses this vulnerability can craft a PDF which leads to large memory usage. This requires parsing the content stream using the RunLengthDecode filter. This has been fixed in pypdf 6.7.4. As a workaround, consider applying the changes from PR #3664.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free