En bref
- CVE-2026-28804 est une vulnérabilité MOYENNE (CVSS 5.3) touchant pypdf, pypdf (pypdf project).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.44%, plus élevée que 38.6% des vulnérabilités.
- Correctif : mettre à jour vers 6.7.5 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| pypdf PyPI | < 6.7.5
| 6.7.5
|
| pypdf | < 6.7.5
| 6.7.5
|
Description
Impact
An attacker who uses this vulnerability can craft a PDF which leads to long runtimes. This requires accessing a stream which uses the /ASCIIHexDecode filter.
Patches
This has been fixed in pypdf==6.7.5.
Workarounds
If you cannot upgrade yet, consider applying the changes from PR #3666.
NVD description
pypdf is a free and open-source pure-python PDF library. Prior to version 6.7.5, an attacker who uses this vulnerability can craft a PDF which leads to long runtimes. This requires accessing a stream which uses the /ASCIIHexDecode filter. This issue has been patched in version 6.7.5.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free