En bref
- CVE-2026-30229 est une vulnérabilité ÉLEVÉE (CVSS 7.2) touchant parse-server (parseplatform), parse-server.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.43%, plus élevée que 37.1% des vulnérabilités.
- Correctif : mettre à jour vers 8.6.6, 9.5.0-alpha.4 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| parse-server | = 9.5.0≥ 9.0.0, ≤ 9.4.1< 8.6.6
| 8.6.6
|
| parse-server npm | ≥ 9.0.0, < 9.5.0-alpha.4< 8.6.6
| 9.5.0-alpha.48.6.6
|
Description
Impact
The readOnlyMasterKey can call POST /loginAs to obtain a valid session token for any user. This allows a read-only credential to impersonate arbitrary users with full read and write access to their data. Any Parse Server deployment that uses readOnlyMasterKey is affected.
Patches
The fix adds a check to the /logInAs handler.
Workarounds
There is no workaround other than not using readOnlyMasterKey.
References
NVD description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.6 and 9.5.0-alpha.4, the readOnlyMasterKey can call POST /loginAs to obtain a valid session token for any user. This allows a read-only credential to impersonate arbitrary users with full read and write access to their data. Any Parse Server deployment that uses readOnlyMasterKey is affected. This issue has been patched in versions 8.6.6 and 9.5.0-alpha.4.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free