En bref
- CVE-2026-30241 est une vulnérabilité ÉLEVÉE (CVSS 8.2) touchant mercurius (mercurius project), mercurius.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.40%, plus élevée que 34.7% des vulnérabilités.
- Correctif : mettre à jour vers 16.8.0 ou plus récent.
Description
Description
Mercurius fails to enforce the configured queryDepth limit on GraphQL subscription queries received over WebSocket connections. The depth check is correctly applied to HTTP queries and mutations, but subscription queries are parsed and executed without invoking the depth validation. This allows a remote client to submit arbitrarily deeply nested subscription queries over WebSocket, bypassing the intended depth restriction. On schemas with recursive types, this can lead to denial of service through exponential data resolution on each subscription event.
Workarounds
Disable subscriptions and, in general, queries over the WebSocket.
NVD description
Mercurius is a GraphQL adapter for Fastify. Prior to version 16.8.0, Mercurius fails to enforce the configured queryDepth limit on GraphQL subscription queries received over WebSocket connections. The depth check is correctly applied to HTTP queries and mutations, but subscription queries are parsed and executed without invoking the depth validation. This allows a remote client to submit arbitrarily deeply nested subscription queries over WebSocket, bypassing the intended depth restriction. On schemas with recursive types, this can lead to denial of service through exponential data resolution on each subscription event. This issue has been patched in version 16.8.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free