En bref
- CVE-2026-30941 est une vulnérabilité ÉLEVÉE (CVSS 7.5) touchant parse-server (parseplatform), parse-server.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.47%, plus élevée que 40.9% des vulnérabilités.
- Correctif : mettre à jour vers 9.5.2, 8.6.14, 9.5.2-alpha.1 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| parse-server | ≥ 9.0.0, < 9.5.2< 8.6.14
| 9.5.28.6.14
|
| parse-server npm | ≥ 9.0.0, < 9.5.2-alpha.1< 8.6.14
| 9.5.2-alpha.18.6.14
|
Description
Impact
A NoSQL injection vulnerability allows an unauthenticated attacker to inject MongoDB query operators via the token field in the password reset and email verification resend endpoints. The token value is passed to database queries without type validation and can be used to extract password reset and email verification tokens.
Any Parse Server deployment using MongoDB with email verification or password reset enabled is affected. When emailVerifyTokenReuseIfValid is configured, the email verification token can be fully extracted and used to verify a user's email address without inbox access.
Patches
Patches
The vulnerability is fixed by adding input type validation at the endpoint level.
Workarounds
There is no known workaround.
References
NVD description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 8.6.14 and 9.5.2-alpha.1, NoSQL injection vulnerability allows an unauthenticated attacker to inject MongoDB query operators via the token field in the password reset and email verification resend endpoints. The token value is passed to database queries without type validation and can be used to extract password reset and email verification tokens. Any Parse Server deployment using MongoDB with email verification or password reset enabled is affected. When emailVerifyTokenReuseIfValid is configured, the email verification token can be fully extracted and used to verify a user's email address without inbox access. This vulnerability is fixed in 8.6.14 and 9.5.2-alpha.1.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free