En bref
- CVE-2026-31856 est une vulnérabilité CRITIQUE (CVSS 9.8) touchant parse-server (parseplatform), parse-server.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.44%, plus élevée que 38.1% des vulnérabilités.
- Correctif : mettre à jour vers 9.6.0, 8.6.29, 9.6.0-alpha.3 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| parse-server | = 9.6.0≥ 9.0.0, < 9.6.0< 8.6.29
| 9.6.08.6.29
|
| parse-server npm | ≥ 9.0.0-alpha.1, < 9.6.0-alpha.3< 8.6.29
| 9.6.0-alpha.38.6.29
|
Description
Impact
A SQL injection vulnerability exists in the PostgreSQL storage adapter when processing Increment operations on nested object fields using dot notation (e.g., stats.counter). The amount value is interpolated directly into the SQL query without parameterization or type validation. An attacker who can send write requests to the Parse Server REST API can inject arbitrary SQL subqueries to read any data from the database, bypassing CLPs and ACLs.
MongoDB deployments are not affected.
Patches
The fix adds type validation to reject non-number values and parameterizes the value in the SQL query instead of interpolating it.
Workarounds
There is no known workaround.
References
NVD description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. A SQL injection vulnerability exists in the PostgreSQL storage adapter when processing Increment operations on nested object fields using dot notation (e.g., stats.counter). The amount value is interpolated directly into the SQL query without parameterization or type validation. An attacker who can send write requests to the Parse Server REST API can inject arbitrary SQL subqueries to read any data from the database, bypassing CLPs and ACLs. MongoDB deployments are not affected. This vulnerability is fixed in 9.6.0-alpha.3 and 8.6.29.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free