En bref
- CVE-2026-32269 est une vulnérabilité MOYENNE (CVSS 6.5) touchant parse-server (parseplatform), parse-server.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.29%, plus élevée que 22.0% des vulnérabilités.
- Correctif : mettre à jour vers 8.6.39, 9.6.0, 9.6.0-alpha.13 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| parse-server | = 9.6.0≥ 8.0.2, < 8.6.39≥ 9.0.0, < 9.6.0
| 8.6.399.6.0
|
| parse-server npm | ≥ 8.0.2, < 8.6.39≥ 9.0.0, < 9.6.0-alpha.13
| 8.6.399.6.0-alpha.13
|
Description
Impact
The OAuth2 authentication adapter does not correctly validate app IDs when appidField and appIds are configured. During app ID validation, a malformed value is sent to the token introspection endpoint instead of the user's actual access token. Depending on the introspection endpoint's behavior, this could either cause all OAuth2 logins to fail, or allow authentication from disallowed app contexts if the endpoint returns valid-looking data for the malformed request.
Deployments using the OAuth2 adapter with appidField and appIds configured are affected.
Patches
The fix corrects the parameter alignment in the OAuth2 adapter's app ID validation method to match the expected interface, ensuring the correct access token is sent to the introspection endpoint.
Workarounds
There is no known workaround.
References
NVD description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.6.0-alpha.13 and 8.6.39, the OAuth2 authentication adapter does not correctly validate app IDs when appidField and appIds are configured. During app ID validation, a malformed value is sent to the token introspection endpoint instead of the user's actual access token. Depending on the introspection endpoint's behavior, this could either cause all OAuth2 logins to fail, or allow authentication from disallowed app contexts if the endpoint returns valid-looking data for the malformed request. Deployments using the OAuth2 adapter with appidField and appIds configured are affected. This vulnerability is fixed in 9.6.0-alpha.13 and 8.6.39.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free