En bref
- CVE-2026-33123 est une vulnérabilité MOYENNE (CVSS 6.5) touchant pypdf, pypdf (pypdf project).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.36%, plus élevée que 29.3% des vulnérabilités.
- Correctif : mettre à jour vers 6.9.1 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| pypdf PyPI | < 6.9.1
| 6.9.1
|
| pypdf | < 6.9.1
| 6.9.1
|
Description
Impact
An attacker who uses this vulnerability can craft a PDF which leads to long runtimes and/or large memory usage. This requires accessing an array-based stream with lots of entries.
Patches
This has been fixed in pypdf==6.9.1.
Workarounds
If you cannot upgrade yet, consider applying the changes from PR #3686.
NVD description
pypdf is a free and open-source pure-python PDF library. Versions prior to 6.9.1 allow an attacker to craft a malicious PDF which leads to long runtimes and/or large memory usage. Exploitation requires accessing an array-based stream with many entries. This issue has been fixed in version 6.9.1.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free