En bref
- CVE-2026-33209 est une vulnérabilité MOYENNE (CVSS 6.1) touchant avo, avo (avohq).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.27%, plus élevée que 19.1% des vulnérabilités.
- Correctif : mettre à jour vers 3.30.3 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| avo RubyGems | < 3.30.3
| 3.30.3
|
| avo | < 3.30.3
| 3.30.3
|
Description
Description
A reflected cross-site scripting (XSS) vulnerability exists in the return_to query parameter used in the avo interface.
An attacker can craft a malicious URL that injects arbitrary JavaScript, which is executed when he clicks a dynamically generated navigation button.
Impact
This vulnerability may allow execution of arbitrary JavaScript in the context of the application.
Impact varies depending on deployment:
- In unauthenticated setups: exploitable via crafted links sent to users
- In authenticated setups: limited to authenticated users and requires interaction
NVD description
Avo is a framework to create admin panels for Ruby on Rails apps. Prior to version 3.30.3, a reflected cross-site scripting (XSS) vulnerability exists in the return_to query parameter used in the avo interface. An attacker can craft a malicious URL that injects arbitrary JavaScript, which is executed when he clicks a dynamically generated navigation button. This issue has been patched in version 3.30.3.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free