En bref
- CVE-2026-33624 est une vulnérabilité FAIBLE (CVSS 2.7) touchant parse-server (parseplatform), parse-server.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.18%, plus élevée que 7.8% des vulnérabilités.
- Correctif : mettre à jour vers 9.6.0, 8.6.60, 9.6.0-alpha.54 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| parse-server | = 9.6.0≥ 9.0.0, < 9.6.0< 8.6.60
| 9.6.08.6.60
|
| parse-server npm | ≥ 9.0.0, < 9.6.0-alpha.54< 8.6.60
| 9.6.0-alpha.548.6.60
|
Description
Impact
An attacker who obtains a user's password and a single MFA recovery code can reuse that recovery code an unlimited number of times by sending concurrent login requests. This defeats the single-use design of recovery codes. The attack requires the user's password, a valid recovery code, and the ability to send concurrent requests within milliseconds.
Patches
The login handler now uses optimistic locking when updating auth data that contains consumed single-use tokens. If a concurrent request has already modified the recovery array, the update fails and the login is rejected.
Workarounds
There are no known workarounds.
NVD description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.60 and 9.6.0-alpha.54, an attacker who obtains a user's password and a single MFA recovery code can reuse that recovery code an unlimited number of times by sending concurrent login requests. This defeats the single-use design of recovery codes. The attack requires the user's password, a valid recovery code, and the ability to send concurrent requests within milliseconds. This issue has been patched in versions 8.6.60 and 9.6.0-alpha.54.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free