En bref
- CVE-2026-34052 est une vulnérabilité MOYENNE (CVSS 5.9) touchant jupyterhub-ltiauthenticator, lti jupyterhub authenticator (jupyter).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.34%, plus élevée que 27.7% des vulnérabilités.
- Correctif : mettre à jour vers 1.6.3 ou plus récent.
Description
Summary
The LTI 1.1 validator stores OAuth nonces in a class-level dictionary that grows without bounds. Nonces are added before signature validation, so an attacker with knowledge of a valid consumer key can send repeated requests with unique nonces to gradually exhaust server memory, causing a denial of service.
Patches
- upgrade jupyterhub-litauthenticator to 1.6.3
NVD description
LTI JupyterHub Authenticator is a JupyterHub authenticator for LTI. Prior to version 1.6.3, the LTI 1.1 validator stores OAuth nonces in a class-level dictionary that grows without bounds. Nonces are added before signature validation, so an attacker with knowledge of a valid consumer key can send repeated requests with unique nonces to gradually exhaust server memory, causing a denial of service. This issue has been patched in version 1.6.3.
Autres vulnérabilités de jupyterhub-ltiauthenticator
Tout voir →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free