En bref
- CVE-2026-34215 est une vulnérabilité MOYENNE (CVSS 6.5) touchant parse-server (parseplatform), parse-server.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.31%, plus élevée que 24.4% des vulnérabilités.
- Correctif : mettre à jour vers 9.7.0, 8.6.63, 9.7.0-alpha.7 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| parse-server | = 9.7.0≥ 9.0.0, < 9.7.0< 8.6.63
| 9.7.08.6.63
|
| parse-server npm | ≥ 9.0.0, < 9.7.0-alpha.7< 8.6.63
| 9.7.0-alpha.78.6.63
|
Description
Impact
The verify password endpoint returns unsanitized authentication data, including MFA TOTP secrets, recovery codes, and OAuth access tokens. An attacker who knows a user's password can extract the MFA secret to generate valid MFA codes, defeating multi-factor authentication protection.
Patches
The verify password endpoint now sanitizes authentication data through auth adapter hooks before returning the response, consistent with login and user retrieval endpoints.
Workarounds
There is no known workaround.
NVD description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.63 and 9.7.0-alpha.7, the verify password endpoint returns unsanitized authentication data, including MFA TOTP secrets, recovery codes, and OAuth access tokens. An attacker who knows a user's password can extract the MFA secret to generate valid MFA codes, defeating multi-factor authentication protection. This issue has been patched in versions 8.6.63 and 9.7.0-alpha.7.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free