En bref
- CVE-2026-34224 est une vulnérabilité MOYENNE (CVSS 4.4) touchant parse-server (parseplatform), parse-server.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.32%, plus élevée que 24.6% des vulnérabilités.
- Correctif : mettre à jour vers 9.7.0, 8.6.64, 9.7.0-alpha.8 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| parse-server | = 9.7.0≥ 9.0.0, < 9.7.0< 8.6.64
| 9.7.08.6.64
|
| parse-server npm | ≥ 9.0.0, < 9.7.0-alpha.8< 8.6.64
| 9.7.0-alpha.88.6.64
|
Description
Impact
An attacker who possesses a valid authentication provider token and a single MFA recovery code or SMS one-time password can create multiple authenticated sessions by sending concurrent login requests via the authData login endpoint. This defeats the single-use guarantee of MFA recovery codes and SMS one-time passwords, allowing session persistence even after the legitimate user revokes detected sessions.
Patches
The fix adds optimistic locking to the authData login path, ensuring that concurrent database updates for the same user fail when the original MFA token array has already been modified by another request.
Workarounds
There is no known workaround.
NVD description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.64 and 9.7.0-alpha.8, an attacker who possesses a valid authentication provider token and a single MFA recovery code or SMS one-time password can create multiple authenticated sessions by sending concurrent login requests via the authData login endpoint. This defeats the single-use guarantee of MFA recovery codes and SMS one-time passwords, allowing session persistence even after the legitimate user revokes detected sessions. This issue has been patched in versions 8.6.64 and 9.7.0-alpha.8.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free