En bref
- CVE-2026-34373 est une vulnérabilité ÉLEVÉE (CVSS 8.8) touchant parse-server (parseplatform), parse-server.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.21%, plus élevée que 10.5% des vulnérabilités.
- Correctif : mettre à jour vers 8.6.66, 9.7.0, 9.7.0-alpha.10 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| parse-server | = 9.7.0≥ 3.5.0, < 8.6.66≥ 9.0.0, < 9.7.0
| 8.6.669.7.0
|
| parse-server npm | ≥ 3.5.0, < 8.6.66≥ 9.0.0, < 9.7.0-alpha.10
| 8.6.669.7.0-alpha.10
|
Description
Impact
The GraphQL API endpoint does not respect the allowOrigin server option and unconditionally allows cross-origin requests from any website. This bypasses origin restrictions that operators configure to control which websites can interact with the Parse Server API. The REST API correctly enforces the configured allowOrigin restriction.
Patches
The GraphQL API endpoint now uses the same CORS middleware as the REST API, ensuring the allowOrigin and allowHeaders server options are consistently enforced across all endpoints.
Workarounds
There is no known workaround other than upgrading.
Resources
NVD description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.66 and 9.7.0-alpha.10, the GraphQL API endpoint does not respect the allowOrigin server option and unconditionally allows cross-origin requests from any website. This bypasses origin restrictions that operators configure to control which websites can interact with the Parse Server API. The REST API correctly enforces the configured allowOrigin restriction. This issue has been patched in versions 8.6.66 and 9.7.0-alpha.10.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free