En bref
- CVE-2026-39847 est une vulnérabilité ÉLEVÉE (CVSS 7.5) touchant emmett, emmett (emmett).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.51%, plus élevée que 44.0% des vulnérabilités.
- Correctif : mettre à jour vers 2.8.1 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| emmett PyPI | ≥ 2.5.0, < 2.8.1
| 2.8.1
|
| emmett | ≥ 2.5.0, < 2.8.1
| 2.8.1
|
Description
The RSGI static handler for Emmett's internal assets (/__emmett__ paths) is vulnerable to path traversal attacks.
An attacker can use ../ sequences (eg /__emmett__/../rsgi/handlers.py) to read arbitrary files outside the assets directory.
NVD description
Emmett is a full-stack Python web framework designed with simplicity. From 2.5.0 to before 2.8.1, the RSGI static handler for Emmett's internal assets (/__emmett__ paths) is vulnerable to path traversal attacks. An attacker can use ../ sequences (eg /__emmett__/../rsgi/handlers.py) to read arbitrary files outside the assets directory. This vulnerability is fixed in 2.8.1.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free