En bref
- CVE-2026-40260 est une vulnérabilité MOYENNE (CVSS 5.3) touchant pypdf, pypdf (pypdf project).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.42%, plus élevée que 36.6% des vulnérabilités.
- Correctif : mettre à jour vers 6.10.0 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| pypdf PyPI | < 6.10.0
| 6.10.0
|
| pypdf | < 6.10.0
| 6.10.0
|
Description
Impact
An attacker who uses this vulnerability can craft a PDF which leads to large memory usage. This requires parsing the XMP metadata.
Patches
This has been fixed in pypdf==6.10.0.
Workarounds
If you cannot upgrade yet, consider applying the changes from PR #3724.
NVD description
pypdf is a free and open-source pure-python PDF library. In versions prior to 6.10.0, manipulated XMP metadata entity declarations can exhaust RAM. An attacker who exploits this vulnerability can craft a PDF which leads to large memory usage. This requires parsing the XMP metadata. This issue has been fixed in version 6.10.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free