En bref
- CVE-2026-40473 est une vulnérabilité ÉLEVÉE (CVSS 8.8) touchant org.apache.camel:camel-mina, camel (apache).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 1.2%, plus élevée que 67.9% des vulnérabilités.
- Correctif : mettre à jour vers 4.14.6, 4.18.2, 4.20.0 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| org.apache.camel:camel-mina Maven | ≥ 3.0.0, < 4.14.6≥ 4.15.0, < 4.18.2≥ 4.19.0, < 4.20.0
| 4.14.64.18.24.20.0
|
| camel | = 4.19.0≥ 3.0.0, < 4.14.6≥ 4.15.0, < 4.18.2
| 4.14.64.18.2
|
Description
The camel-mina component's MinaConverter.toObjectInput(IoBuffer) type converter wraps an IoBuffer in a java.io.ObjectInputStream without applying any ObjectInputFilter or class-loading restrictions. When a Camel route uses camel-mina as a TCP or UDP consumer and requests conversion to ObjectInput (for example via getBody(ObjectInput.class) or @Body ObjectInput), an attacker sending a crafted serialized Java object over the network to the MINA consumer port can trigger arbitrary code execution in the context of the application during readObject().
This issue affects Apache Camel: from 3.0.0 before 4.14.6, from 4.15.0 before 4.18.2, from 4.19.0 before 4.20.0.
Users are recommended to upgrade to version 4.20.0, which fixes the issue. If users are on the 4.14.x LTS releases stream, then they are suggested to upgrade to 4.14.6. If users are on the 4.18.x releases stream, then they are suggested to upgrade to 4.18.2.
NVD description
The camel-mina component's MinaConverter.toObjectInput(IoBuffer) type converter wraps an IoBuffer in a java.io.ObjectInputStream without applying any ObjectInputFilter or class-loading restrictions. When a Camel route uses camel-mina as a TCP or UDP consumer and requests conversion to ObjectInput (for example via getBody(ObjectInput.class) or @Body ObjectInput), an attacker sending a crafted serialized Java object over the network to the MINA consumer port can trigger arbitrary code execution in the context of the application during readObject().
This issue affects Apache Camel: from 3.0.0 before 4.14.6, from 4.15.0 before 4.18.2, from 4.19.0 before 4.20.0.
Users are recommended to upgrade to version 4.20.0, which fixes the issue. If users are on the 4.14.x LTS releases stream, then they are suggested to upgrade to 4.14.6. If users are on the 4.18.x releases stream, then they are suggested to upgrade to 4.18.2.
Autres vulnérabilités de org.apache.camel:camel-mina
Tout voir →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free