En bref
- CVE-2026-41014 est une vulnérabilité MOYENNE (CVSS 4.3) touchant apache-airflow, airflow (apache).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.37%, plus élevée que 30.4% des vulnérabilités.
- Correctif : mettre à jour vers 3.2.2 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| apache-airflow PyPI | ≥ 3.2.0, < 3.2.2
| 3.2.2
|
| airflow | ≥ 3.2.0, < 3.2.2
| 3.2.2
|
Description
The partitioned_dag_runs endpoints in the Airflow UI enforced only asset-level access control, not per-Dag authorization. An authenticated UI/API user with global Asset:read permission could enumerate partition run state, schedule configuration, and asset wiring for Dags they were not authorized to read. Affects deployments that rely on per-Dag read scoping while granting users broader Asset access. Users are advised to upgrade to apache-airflow 3.2.2 or later.
NVD description
The partitioned_dag_runs endpoints in the Airflow UI enforced only asset-level access control, not per-Dag authorization. An authenticated UI/API user with global Asset:read permission could enumerate partition run state, schedule configuration, and asset wiring for Dags they were not authorized to read. Affects deployments that rely on per-Dag read scoping while granting users broader Asset access. Users are advised to upgrade to `apache-airflow` 3.2.2 or later.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free