En bref
- CVE-2026-41168 est une vulnérabilité MOYENNE (CVSS 5.3) touchant pypdf, pypdf (pypdf project).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.30%, plus élevée que 22.4% des vulnérabilités.
- Correctif : mettre à jour vers 6.10.1 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| pypdf PyPI | < 6.10.1
| 6.10.1
|
| pypdf | < 6.10.1
| 6.10.1
|
Description
Impact
An attacker who uses this vulnerability can craft a PDF which leads to long runtimes. This requires cross-reference streams with wrong large /Size values or object streams with wrong large /N values.
Patches
This has been fixed in pypdf==6.10.1.
Workarounds
If you cannot upgrade yet, consider applying the changes from PR #3733.
NVD description
pypdf is a free and open-source pure-python PDF library. An attacker who uses a vulnerability present in versions prior to 6.10.1 can craft a PDF which leads to long runtimes. This requires cross-reference streams with wrong large `/Size` values or object streams with wrong large `/N` values. This has been fixed in pypdf 6.10.1. As a workaround, one may apply the changes from the patch manually.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free