En bref
- CVE-2026-41314 est une vulnérabilité MOYENNE (CVSS 6.5) touchant pypdf, pypdf (py-pdf).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.23%, plus élevée que 13.4% des vulnérabilités.
- Correctif : mettre à jour vers 6.10.2 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| pypdf PyPI | < 6.10.2
| 6.10.2
|
| pypdf | < 6.10.2
| 6.10.2
|
Description
Impact
An attacker who uses this vulnerability can craft a PDF which leads to the RAM being exhausted. This requires accessing an image using /FlateDecode with large size values.
Patches
This has been fixed in pypdf==6.10.2.
Workarounds
If you cannot upgrade yet, consider applying the changes from PR #3734.
NVD description
pypdf is a free and open-source pure-python PDF library. An attacker who uses a vulnerability present in versions prior to 6.10.2 can craft a PDF which leads to the RAM being exhausted. This requires accessing an image using `/FlateDecode` with large size values. This has been fixed in pypdf 6.10.2. As a workaround, one may apply the changes from the patch manually.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free