En bref
- CVE-2026-42308 est une vulnérabilité MOYENNE (CVSS 5.5) touchant pillow, pillow (python).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.11%, plus élevée que 1.4% des vulnérabilités.
- Correctif : mettre à jour vers 12.2.0 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| pillow PyPI | < 12.2.0
| 12.2.0
|
| pillow | < 12.2.0
| 12.2.0
|
Description
If a font advances for each glyph by an exceeding large amount, when Pillow keeps track of the current position, it may lead to an integer overflow. This has been fixed.
NVD description
Pillow is a Python imaging library. Prior to version 12.2.0, if a font advances for each glyph by an exceeding large amount, when Pillow keeps track of the current position, it may lead to an integer overflow. This issue has been patched in version 12.2.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free