En bref
- CVE-2026-42309 est une vulnérabilité MOYENNE (CVSS 5.5) touchant pillow, pillow (python).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.13%, plus élevée que 2.8% des vulnérabilités.
- Correctif : mettre à jour vers 12.2.0 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| pillow PyPI | ≥ 11.2.1, < 12.2.0
| 12.2.0
|
| pillow | ≥ 11.2.1, < 12.2.0
| 12.2.0
|
Description
Passing nested lists as coordinates to APIs that accept coordinates such as ImagePath.Path, ImageDraw.ImageDraw.polygon and ImageDraw.ImageDraw.line could cause a heap buffer overflow, as nested lists were recursively unpacked beyond the allocated buffer. Coordinate lists are now validated to contain exactly two numeric coordinates. This was introduced in Pillow 11.2.1.
NVD description
Pillow is a Python imaging library. From version 11.2.1 to before version 12.2.0, passing nested lists as coordinates to APIs that accept coordinates such as ImagePath.Path, ImageDraw.ImageDraw.polygon and ImageDraw.ImageDraw.line could cause a heap buffer overflow, as nested lists were recursively unpacked beyond the allocated buffer. Coordinate lists are now validated to contain exactly two numeric coordinates. This issue has been patched in version 12.2.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free