En bref
- CVE-2026-42573 est une vulnérabilité MOYENNE (CVSS 6.1) touchant svelte (svelte), svelte.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.34%, plus élevée que 27.8% des vulnérabilités.
- Correctif : mettre à jour vers 5.55.7 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| svelte | < 5.55.7
| 5.55.7
|
| svelte npm | < 5.55.7
| 5.55.7
|
Description
Svelte was vulnerable to DOM clobbering of its internal framework state on elements, potentially leading to XSS attacks.
You are vulnerable if all of the following is true:
- you are using attribute spreading on a form element
- you are using attribute spreading or allow a dynamic value for the
name attribute on an input or button element within that form
- both of these are simultaneously user-controllable
<form {...spread1}>
<input {...spread2}>
</form>
NVD description
Svelte is a performance oriented web framework. Prior to version 5.55.7, Svelte was vulnerable to DOM clobbering of its internal framework state on elements, potentially leading to XSS attacks. This issue has been patched in version 5.55.7.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free