En bref
- CVE-2026-44262 est une vulnérabilité CRITIQUE (CVSS 9.4) touchant dedoc/scramble.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 5.9%, plus élevée que 93.2% des vulnérabilités.
- Correctif : mettre à jour vers 0.13.22 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| dedoc/scramble Packagist | ≥ 0.13.2, < 0.13.22
| 0.13.22
|
Description
Impact
A remote code execution (RCE) vulnerability affects versions 0.13.2 through 0.13.21. When documentation endpoints are publicly accessible and validation rules reference user-controlled input, request supplied data may be evaluated during documentation generation, leading to execution of arbitrary PHP code in the application context.
Patches
Fixed in version 0.13.22.
Workarounds
If upgrading is not immediately possible:
- Restrict access to documentation endpoints (
/docs/api, /docs/api.json)
- Avoid using user-controlled variables inside validation rule expressions (e.g., values derived from request input)
- Disable documentation endpoints in production environments if not required
These measures significantly reduce or prevent exploitability.
NVD description
Scramble generates API documentation for Laravel project. From 0.13.2 to before 0.13.22, when documentation endpoints are publicly accessible and validation rules reference user-controlled input, request supplied data may be evaluated during documentation generation, leading to execution of arbitrary PHP code in the application context. This vulnerability is fixed in 0.13.22.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free