En bref
- CVE-2026-45106 est une vulnérabilité MOYENNE (CVSS 4.6) touchant weblate.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.21%, plus élevée que 10.9% des vulnérabilités.
- Correctif : mettre à jour vers 2026.5 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| weblate PyPI | < 2026.5
| 2026.5
|
Description
Impact
Weblate's live search preview renders unit source and context as HTML without escaping. Any contributor whose content reaches those fields stores HTML and CSS that runs inside the authenticated editor of every user who runs a matching search.
Patches
Workarounds
Only the search preview on the selected views is affected.
Resources
Weblate thanks @adrgs for reporting this issue responsibly via GitHub.
NVD description
Weblate is a web based localization tool. Prior to version 2026.5, Weblate's live search preview renders unit source and context as HTML without escaping. Any contributor whose content reaches those fields stores HTML and CSS that runs inside the authenticated editor of every user who runs a matching search. This issue has been patched in version 2026.5.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free