En bref
- CVE-2026-45149 est une vulnérabilité ÉLEVÉE (CVSS 7.5) touchant brace-expansion (juliangruber), brace-expansion.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.30%, plus élevée que 22.9% des vulnérabilités.
- Correctif : mettre à jour vers 5.0.6 ou plus récent.
Description
The max option was being applied too late:
When expanding a single large numeric range like {1..10000000}, the sequence generation loop generates all 10 million intermediate elements before the max limit is applied With max=10, the output is correctly limited to 10 items, but the process still allocates ~505 MB and spends ~800ms building the full intermediate array.
Workaround
Ensure the string to be expanded doesn't contain more values than the desired max item count.
NVD description
The brace-expansion library generates arbitrary strings containing a common prefix and suffix. From 5.0.0 to before 5.0.6, the max option was being applied too late. When expanding a single large numeric range like {1..10000000}, the sequence generation loop generates all 10 million intermediate elements before the max limit is applied With max=10, the output is correctly limited to 10 items, but the process still allocates ~505 MB and spends ~800ms building the full intermediate array. This vulnerability is fixed in 5.0.6.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free