En bref
- CVE-2026-48207 est une vulnérabilité CRITIQUE (CVSS 9.8) touchant pyfory, fory (apache).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.57%, plus élevée que 47.4% des vulnérabilités.
- Correctif : mettre à jour vers 1.0.0 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| pyfory PyPI | ≥ 0.13.0, < 1.0.0
| 1.0.0
|
| fory | ≥ 0.13.0, < 1.0.0
| 1.0.0
|
Description
Fory PyFory's ReduceSerializer could bypass documented DeserializationPolicy validation hooks during reduce-state restoration and global-name resolution. An application is vulnerable if it deserializes attacker-controlled data using PyFory Python-native mode with strict mode disabled and relies on DeserializationPolicy to restrict unsafe classes, functions, or module attributes.
This issue affects Apache Fory: from before 1.0.0.
Mitigation: Users of Apache Fory are recommended to upgrade to version 1.0.0 or later, which enforces DeserializationPolicy validation for the affected ReduceSerializer paths and thus fixes this issue.
NVD description
Deserialization of untrusted data in Apache Fory PyFory. PyFory's ReduceSerializer could bypass documented DeserializationPolicy validation hooks during reduce-state restoration and global-name resolution. An application is vulnerable if it deserializes attacker-controlled data using PyFory Python-native mode with strict mode disabled and relies on DeserializationPolicy to restrict unsafe classes, functions, or module attributes.
This issue affects Apache Fory: from before 1.0.0.
Mitigation: Users of Apache Fory are recommended to upgrade to version 1.0.0 or later, which enforces DeserializationPolicy validation for the affected ReduceSerializer paths and thus fixes this issue.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free