En bref
- CVE-2026-49460 est une vulnérabilité FAIBLE (CVSS 3.3) touchant pypdf, pypdf (pypdf project).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.17%, plus élevée que 5.8% des vulnérabilités.
- Correctif : mettre à jour vers 6.12.2 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| pypdf PyPI | < 6.12.2
| 6.12.2
|
| pypdf | < 6.12.2
| 6.12.2
|
Description
Impact
An attacker who uses this vulnerability can craft a PDF which leads to long runtimes. This requires accessing a stream which uses the /FlateDecode filter with a PNG predictor.
Patches
This has been fixed in pypdf==6.12.2.
Workarounds
If you cannot upgrade yet, consider applying the changes from PR #3806.
NVD description
pypdf is a free and open-source pure-python PDF library. Prior to 6.12.2, an attacker who uses this vulnerability can craft a PDF which leads to long runtimes. This requires accessing a stream which uses the /FlateDecode filter with a PNG predictor. This vulnerability is fixed in 6.12.2.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free