| Package | Affected versions | Patched versions |
|---|---|---|
| org.apache.cxf:cxf-integration-jca | ≥ 4.2.0, < 4.2.2< 4.1.7 | 4.2.24.1.7 |
| cxf | ≥ 4.2.0, < 4.2.2< 4.1.7 | 4.2.24.1.7 |
A JNDI Injection vulnerability has been discovered in Apache CXF's JCA integration module, which can allow for code execution, if an attacker is able to manipulate the JCA deployment descriptor (ra.xml) or runtime activation parameters. Users are recommended to upgrade to versions 4.2.2 or 4.1.7, which fixes this issue.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free