En bref
- CVE-2026-53718 est une vulnérabilité MOYENNE (CVSS 6.4) touchant github.com/envoyproxy/gateway.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.41%, plus élevée que 35.6% des vulnérabilités.
- Correctif : mettre à jour vers 1.8.1, 1.7.4 ou plus récent.
Description
Impact
Envoy Gateway accepts extension-managed custom backendRefs from an HTTPRoute to a backend resource in another namespace without requiring a matching Gateway API ReferenceGrant in the target namespace. This breaks the Gateway API cross-namespace consent model: the namespace that owns the referenced backend resource does not need to opt in with a ReferenceGrant before another namespace’s HTTPRoute can use that resource.
Patches
1.7.4
1.8.1
NVD description
Envoy Gateway is an open source project for managing Envoy Proxy as a standalone or Kubernetes-based application gateway. Prior to 1.7.4 and 1.8.1, an HTTPRoute can use an extension-managed custom backendRef to reference a backend resource in another namespace without a matching Gateway API ReferenceGrant in the target namespace. The custom-backend branch in internal/gatewayapi/route.go omits validateBackendNamespace, allowing the route-owning namespace to bind to and use the resource without the backend namespace owner's consent and violating the Gateway API cross-namespace authorization model. This issue is fixed in versions 1.7.4 and 1.8.1.
Autres vulnérabilités de github.com/envoyproxy/gateway
Tout voir →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free