En bref
- CVE-2026-55211 est une vulnérabilité CRITIQUE (CVSS 9.8) touchant surfio.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.74%, plus élevée que 54.8% des vulnérabilités.
- Correctif : mettre à jour vers 0.0.19 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| surfio PyPI | < 0.0.19
| 0.0.19
|
Description
Impact
Prior to version 0.0.19, surfio would not correctly validate size fields in irap files, leading to a buffer overflow . The severity rating assumes that surfio is used to parse untrused files in a networking context such as a web service.
Patches
The bug has been patched in version 0.0.19
NVD description
Surfio is a library for reading and writing surface files. Prior to 0.0.19, surfio does not correctly validate size fields in IRAP files, leading to a buffer overflow when untrusted files are parsed. The severity assumes surfio is used to parse untrusted files in a networking context such as a web service. This issue is fixed in version 0.0.19.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free