En bref
- CVE-2026-56349 est une vulnérabilité MOYENNE (CVSS 6.3) touchant n8n.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.47%, plus élevée que 40.8% des vulnérabilités.
- Correctif : mettre à jour vers 2.10.0 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| n8n npm | < 2.10.0
| 2.10.0
|
Description
Impact
An end user interacting with a workflow that uses the Guardrail node could craft an input that bypasses the default guardrail instructions.
Patches
The issue has been fixed in n8n version 2.10.0. Users should upgrade to this version or later to remediate the vulnerability.
Workarounds
If upgrading is not immediately possible, administrators should consider the following temporary mitigations:
- Limit access to trusted users.
- Review asses the practical impact of guardrail bypasses in your usecase and adjust your workflow accordingly.
These workarounds do not fully remediate the risk and should only be used as short-term mitigation measures.
NVD description
n8n before version 2.10.0 contains an input validation vulnerability in the Guardrail node that allows attackers to bypass default guardrail instructions. End users can craft malicious inputs to circumvent guardrail protections and compromise workflow integrity.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free