En bref
- CVE-2026-56817 est une vulnérabilité CRITIQUE (CVSS 9.8) touchant io.netty:netty-codec-xml, netty (netty).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.69%, plus élevée que 53.0% des vulnérabilités.
- Correctif : mettre à jour vers 4.1.136.Final, 4.2.16.Final, 4.1.136, 4.2.16 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| io.netty:netty-codec-xml Maven | ≥ 4.1.0.Final, < 4.1.136.Final≥ 4.2.0.Final, < 4.2.16.Final
| 4.1.136.Final4.2.16.Final
|
| netty | ≥ 4.1.0, < 4.1.136≥ 4.2.0, < 4.2.16
| 4.1.1364.2.16
|
Description
Any caller that can deliver bytes to a Netty channel pipeline containing XmlDecoder can send XML with a DOCTYPE declaration to a parser instantiated with no security configuration — but whether external entities are actually resolved depends on Aalto XML's async parser behavior, making this a confirmed misconfiguration with conditional exploitability.
NVD description
Netty is a network application framework for development of protocol servers and clients. In versions 4.2.0.Final through 4.2.15.Final and 4.1.0.Final through 4.1.135.Final, any caller that can deliver bytes to a Netty channel pipeline containing `XmlDecoder` can send XML with a `DOCTYPE` declaration to an `AsyncXMLInputFactory` instantiated with no security configuration, leaving DTD and entity handling active depending on Aalto XML async parser behavior and creating conditional XML external entity risk. This issue is fixed in versions 4.1.136.Final and 4.2.16.Final.
Autres vulnérabilités de io.netty:netty-codec-xml
Tout voir →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free