En bref
- CVE-2026-59901 est une vulnérabilité ÉLEVÉE (CVSS 7.5) touchant io.netty:netty-codec, io.netty:netty-codec-compression, netty (netty).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.46%, plus élevée que 39.9% des vulnérabilités.
- Correctif : mettre à jour vers 4.1.136.Final, 4.2.16.Final, 4.2.16, 4.1.136 ou plus récent.
Description
The Bzip2Decoder handler in Netty's compression codec pipeline is vulnerable to a denial-of-service attack through a malformed bzip2 stream that permanently captures the event-loop thread in an infinite loop. The vulnerability exists in the run-length encoding (RLE) state machine within [Bzip2BlockDecompressor.read()]
NVD description
Netty is an asynchronous, event-driven network application framework. Prior to versions 4.1.136.Final and 4.2.16.Final, the `Bzip2Decoder` handler in Netty's compression codec pipeline is vulnerable to a denial-of-service attack through a malformed bzip2 stream that permanently captures the event-loop thread in an infinite loop. The vulnerability exists in the run-length encoding (RLE) state machine within [`Bzip2BlockDecompressor.read()`]. This issue has been fixed in versions 4.1.136.Final and 4.2.16.Final.
Autres vulnérabilités de io.netty:netty-codec
Tout voir →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free