| Package | Affected versions | Patched versions |
|---|---|---|
| activemq | ≥ 6.0.0, < 6.3.2< 5.19.11 | 6.3.25.19.11 |
| activemq all | ≥ 6.0.0, < 6.3.2< 5.19.11 | 6.3.25.19.11 |
| activemq broker | ≥ 6.2.0, < 6.3.2< 5.19.11 | 6.3.25.19.11 |
Improper input validation in TopicRegion in Apache ActiveMQ, Apache ActiveMQ Broker, and Apache ActiveMQ All on all platforms. An authenticated client can spoof clientId when removing a durable topic subscription. This issue affects Apache ActiveMQ Broker: before 5.19.11, from 6.0.0 before 6.3.2; Apache ActiveMQ All: before 5.19.11, from 6.0.0 before 6.3.2; Apache ActiveMQ: before 5.19.11, from 6.0.0 before 6.3.2. Users are recommended to upgrade to version 6.3.2 or 5.19.11 which fixes the issue.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free